Version 1.1.5

Released on 2017/06/12.

Note

If you are upgrading a cluster, you must be running CrateDB 0.57.0 or higher before you upgrade to 1.1.5.

If you want to perform a rolling upgrade, your current CrateDB version number must be Version 1.1.1 or higher. If you want to upgrade from a version prior to this, the upgrade will introduce all of the breaking changes listed for Version 1.1.0, and will require a full restart upgrade.

Warning

Before upgrading, you should back up your data.

Changelog

Fixes

  • Fixed an issue that leads to an exception if the statement evaluates on arrays that are provided in an aggregation function.
  • Fixed a performance regression that could cause JOIN queries to execute slower than they used to.
  • Return proper exception when group by is used on scalar functions that are applied to an aggregation.
  • Fixed an issue that causes aliases used in the select list to get lost on subselect queries.
  • The correct error messages and codes are now thrown for REST actions.
  • Fixed an issue that could cause non-grouping aggregations on virtual tables to return the wrong result.
  • Fixed a bug in the memory accounting of the circuit breaker for HTTP results when querying GEO_SHAPE columns.
  • Reflect internally used default size for translog.flush_threshold_size also in documentation and expose the correct default value in table settings.